Bus 13, 16, 22, 24 & 36 has a sub driver (Possible Delay) 5/9/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted May 10, 2024 - 05:38 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 09, 2024 - 13:41 EDT
This incident affected: Transportation (Bus 13, Bus 16, Bus 22, Bus 24, Bus 36).