Bus#31 - Has a sub driver today. Expect possible delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Nov 23, 2021 - 09:42 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 23, 2021 - 07:37 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 23, 2021 - 07:29 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 23, 2021 - 07:19 EST
Identified
Bus #31 is running approx 25 minutes behind for elementary school.

OMS expect some delays. To lessen the delay please see the following:
Bus #31 OMS Bus #25 will be picking up all stops in the landing
Bus#20 will pick up stop on Watersail Way and the remaining stops will be picked up by Bus #31
Posted Nov 23, 2021 - 06:16 EST
Investigating
We are currently investigating this issue.
Posted Nov 23, 2021 - 05:27 EST
This incident affected: Transportation (Bus 31).