Bus #4 - Sub driver - Expect possible delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 10, 2022 - 08:50 EST
Update
We are continuing to investigate this issue.
Posted Jan 10, 2022 - 05:31 EST
Investigating
We are currently investigating this issue.
Posted Jan 10, 2022 - 05:26 EST
This incident affected: Transportation (Bus 04).