Bus #22 - Sub on Bus for Elementary School only. Middle School and High School expect Bus # 22 or Bus # 23 to pick up this morning. Expect possible delays due to double routing.
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 08:50 EST
Investigating
We are currently investigating this issue.
Posted Jan 11, 2022 - 05:47 EST
This incident affected: Transportation (Bus 22, Bus 23, Bus 25).