Bus 1, 12, 17, 29, 35 & 49 has a sub driver (Possible Delays) 9/10/2024
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 10, 2024 - 09:20 EDT
Update
We are continuing to monitor for any further issues.
Posted Sep 10, 2024 - 06:35 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2024 - 06:09 EDT
This incident affected: Transportation (Bus 01, Bus 12, Bus 17, Bus 29, Bus 35, Bus 49).