Buses 15 & 31 will be combined on bus 31 for Bethany (Expect Delays) 3/3/26

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 18:06 EST

Monitoring

Bus 11 will be on bus 15 for Bethany
Posted Mar 03, 2026 - 14:08 EST
This incident affected: Transportation (Bus 11, Bus 15, Bus 31).