Bus #31 has a sub driver
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted May 13, 2022 - 08:57 EDT
Investigating
We are currently investigating this issue.
Posted May 13, 2022 - 05:34 EDT