Bus 16 will be split between buses 18 & 30 for OMS & CHS/NGC (Possible Delays) 9/6/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 09, 2024 - 05:24 EDT
Monitoring
Mountainview, Crosswind, Timbers, Charlotte Hwy, Baird Rd stops will ride bus 18
Boulder, Liberty Hill, Fermont, Rockledge will ride bus 30
Posted Sep 06, 2024 - 12:57 EDT
This incident affected: Transportation (Bus 16, Bus 18, Bus 30).