Buses 1 & 35 will be combined on bus 35 for CCES (Possible Delays) 8/25/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 06:22 EDT

Monitoring

Bus 35 will be 1st load
Bus 1 will be 2nd load
Posted Aug 25, 2025 - 14:05 EDT
This incident affected: Transportation (Bus 01, Bus 35).