Bus 4, 11, 12 & 35 has a sub driver (Possible Delays) 2/6/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Feb 07, 2025 - 05:16 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2025 - 13:38 EST
This incident affected: Transportation (Bus 04, Bus 11, Bus 12, Bus 35).