Bus 49 will be split between buses 33 & 49 for OMS & CHS/NGC (Possible Delays) 4/26/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 09:36 EDT
Monitoring
The Bluffs will ride on bus 46
The Landings will ride on bus 33
Posted Apr 26, 2024 - 06:46 EDT
This incident affected: Transportation (Bus 33, Bus 46, Bus 49).