Bus 18's route with regards to the stop on Kreps Rd
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 10:05 EDT
Monitoring
Due to safety concerns, the road conditions along Kreps Rd have deteriorated, making it unsafe for the bus to turn around. Consequently, we have had to make changes to the route. Effective Wednesday, April 24, 2024, the last stop on Kreps Rd will now be located at the corner of Kreps Rd & Tennessee Walker Rd.
Please note that any stops beyond Tennessee Walker Rd will no longer be serviced by the bus. Students who typically disembark at stops past Tennessee Walker Rd will need to walk up to Tennessee Walker Rd for the designated bus stop.
Posted Apr 24, 2024 - 06:08 EDT
This incident affected: Transportation (Bus 18).