Buses 13 & 22 are combined on bus 13 for CHS/NGC (Possible Delays) 4/24/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 17:05 EDT
Monitoring
Students who live on Ormand Rd will ride bus 9 for CMS & CHS/NGC
Posted Apr 24, 2024 - 13:30 EDT
This incident affected: Transportation (Bus 09, Bus 13, Bus 22).