Buses 48 & 53 will be combined on bus 48 for OMS & CHS (Possible Delays) 3/25/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 17:41 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2025 - 13:20 EDT
This incident affected: Transportation (Bus 48, Bus 53).