Buses 1 & 48 will be combined on bus 48 for CCES (Possible Delays) 9/23/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 24, 2024 - 05:30 EDT
Monitoring
Bus 48 will be 1st load
Bus 1 will be 2nd load
Posted Sep 23, 2024 - 13:23 EDT
This incident affected: Transportation (Bus 01, Bus 48).