Bus #2 - will be split between 2 buses. Expect Bus #29 , Bus #1 or Bus #7 to be picking up for Bus #2 this morning. BUS #2 will be taking all of BUS #3's students
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 09:33 EST
Investigating
We are currently investigating this issue.
Posted Jan 11, 2022 - 05:41 EST
This incident affected: Transportation (Bus 01, Bus 02, Bus 07, Bus 29).