Bus 32, 37, 42, 43, 44, 48 & 60 has a sub driver (Possible Delays) 8/21/26

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Aug 23, 2026 - 21:12 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2026 - 15:05 EDT
This incident affected: Transportation (Bus 32, Bus 37, Bus 42, Bus 43, Bus 44, Bus 48, Bus 60).