Bus #49 and Bus #25 will be combined. For Elem Bus #25 will be first load and #49 will be second load. OMS and CHS Bus 49 will be spilt between Bus #33 and #46. The landing stops will ride Bus #33 and The Bluffs will ride Bus #46
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 05:38 EDT
Investigating
We are currently investigating this issue.
Posted Apr 12, 2024 - 12:47 EDT
This incident affected: Transportation (Bus 25, Bus 33, Bus 49).