Buses 35 & 48 will be combined on bus 48 for CCES, OMS & CHS (Possible Delays) 9/11/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 11, 2024 - 09:21 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2024 - 06:20 EDT
This incident affected: Transportation (Bus 35, Bus 48).