Bus # 22 (route #2) shuttling Bus #3 to CMS

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 22, 2023 - 17:15 EDT

Investigating

We are currently investigating this issue.
Posted Mar 22, 2023 - 15:34 EDT
This incident affected: Transportation (Bus 22).