Bus 9 CHS will be split between Bus 4, 12, 16, & 34, expect delays
Incident Report for Clover School District
Resolved
We are continuing to monitor for any further issues.
Posted Oct 05, 2022 - 09:17 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 05, 2022 - 09:17 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 05, 2022 - 09:16 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 05, 2022 - 08:38 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 05, 2022 - 06:05 EDT
This incident affected: Transportation (Bus 04, Bus 09, Bus 16, Bus 34, Bus 12).