HIGH SCHOOL MORNING ROUTE- Bus #35 will be covering for Bus #32. There may be possible delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 11:15 EST
Investigating
We are currently investigating this issue.
Posted Nov 06, 2024 - 08:01 EST
This incident affected: Transportation (Bus 32, Bus 35).