Buses 35 & 48 will be combined on bus 48 for CCES, OMS & CHS (Possible Delays) 5/16/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted May 16, 2025 - 17:14 EDT

Monitoring

Bus 48 will be 1st load
Bus 35 will be 2nd load
Posted May 16, 2025 - 13:04 EDT
This incident affected: Transportation (Bus 35, Bus 48).