Expect Delays bus 3 is running behind 10/15/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Oct 15, 2024 - 10:13 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2024 - 06:41 EDT
This incident affected: Transportation (Bus 03).