Expect Delays: Bus 15 is experiencing some mechanical issues 2/14/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 07:46 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2025 - 14:33 EST
This incident affected: Transportation (Bus 15).