Buses 1 & 36 will be combined on bus 36 for CCES, OMS & CHS (Possible Delays) 5/15/26

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted May 15, 2026 - 18:21 EDT

Monitoring

Marlin Bay will be on bus 60 (OMS) and bus 49 (CHS)
Posted May 15, 2026 - 13:46 EDT
This incident affected: Transportation (Bus 01, Bus 36, Bus 49, Bus 60).