Bus #9 - Sub driver. Expect possible delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 10, 2022 - 08:51 EST
Investigating
We are currently investigating this issue.
Posted Jan 10, 2022 - 05:23 EST
This incident affected: Transportation (Bus 09).