Bus #5 will be helping pick up Bus #29's students for Elementary
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 09:33 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 11, 2022 - 06:41 EST
This incident affected: Transportation (Bus 05, Bus 29).