Bus 49 will be split between Bus 27 & Bus 46 for OMS & CHS (Possible Delays) 8/12/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 18:01 EDT

Monitoring

The Bluffs will be on bus 46
The Landings will be on 27
Posted Aug 12, 2025 - 13:46 EDT
This incident affected: Transportation (Bus 27, Bus 46, Bus 49).