Bus 34, 35 & 49 has a sub driver (Possible Delays) 9/11/2024
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 11, 2024 - 09:21 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2024 - 06:03 EDT
This incident affected: Transportation (Bus 34, Bus 35, Bus 49).