Bus #41 will ride on Bus #43 with #43 Elementary. Sub driver on Bus 43
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted May 24, 2022 - 08:52 EDT
Investigating
We are currently investigating this issue.
Posted May 24, 2022 - 06:02 EDT
This incident affected: Transportation (Bus 41, Bus 42).