Bus 4, 11, 15 & 35 has a sub driver (Possible Delays) 2/4/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 10:15 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2025 - 06:31 EST
This incident affected: Transportation (Bus 04, Bus 11, Bus 15, Bus 35).