BUS 31 IS RUNNING 30 MINUTES BEHIND ON CMS ROUTE.
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 29, 2022 - 08:48 EDT
Investigating
We are currently investigating this issue.
Posted Sep 29, 2022 - 08:19 EDT
This incident affected: Transportation (Bus 31).