Bus # 39 = Sub Driver, expect Delay
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Mar 23, 2023 - 09:44 EDT
Investigating
We are currently investigating this issue.
Posted Mar 23, 2023 - 06:37 EDT
This incident affected: Transportation (Bus 39).