Bus #22 has a sub driver for Elementary. Middle School and High School Bus #25 will take Bus #22's students. Bus #23 will take Bus #25's students
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 17:21 EST
Investigating
We are currently investigating this issue.
Posted Jan 14, 2022 - 13:55 EST
This incident affected: Transportation (Bus 22, Bus 23, Bus 25).