Bus 9 CMS/CHS will be split between Bus 12, 4, 20 & 16, expect delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Oct 06, 2022 - 10:17 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 06, 2022 - 05:50 EDT
This incident affected: Transportation (Bus 04, Bus 09, Bus 16, Bus 20, Bus 12).