Buses 9 & 34 will be combined on bus 9 for LES (Expect Delays) 10/18/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Oct 18, 2024 - 10:24 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2024 - 06:46 EDT
This incident affected: Transportation (Bus 09, Bus 34).