Expect Delays: Bus 54 is running about 10-15 minutes behind 3/27/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 08:22 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2025 - 06:58 EDT
This incident affected: Transportation (Bus 54).