Bus #9 - Sub driver
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 08:52 EST
Update
We are continuing to investigate this issue.
Posted Jan 14, 2022 - 08:52 EST
Investigating
We are currently investigating this issue.
Posted Jan 14, 2022 - 06:16 EST
This incident affected: Transportation (Bus 09).