Bus 6, 15, 28, 29, 36 & 43 has a sub driver (Possible Delay) 8/29/2024
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Aug 29, 2024 - 09:25 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 29, 2024 - 06:52 EDT
This incident affected: Transportation (Bus 06, Bus 15, Bus 28, Bus 29, Bus 36, Bus 43).