Bus 54 has a sub driver (Possible Delays) 2/11/26

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 14:06 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 11, 2026 - 06:29 EST
This incident affected: Transportation (Bus 54).