Expect Delays: CCES 4/1/26

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 05:46 EDT

Monitoring

All Crowders Creek Elementary buses will be delayed approximately 15–25 minutes dropping off students due to a bus returning late from a field trip.
Posted Apr 01, 2026 - 14:00 EDT
This incident affected: Transportation (Bus 01, Bus 08, Bus 09, Bus 19, Bus 26, Bus 27, Bus 30, Bus 35, Bus 36, Bus 41, Bus 44, Bus 48, Bus 50, Bus 60).