Buses 25 & 49 will be combined on bus 49 for OES (Possible Delays) 9/11/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 11, 2024 - 07:12 EDT
Monitoring
The Bluffs will ride bus 46
Posted Sep 11, 2024 - 06:22 EDT
This incident affected: Transportation (Bus 25, Bus 46, Bus 49).