Road Closure: Bus 46 OES, OMS & CHS 11/18/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 06:24 EST

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 14:16 EST

Monitoring

Due to a road closure on River Oaks, parents/guardians will need to meet bus 46 at the corner of River Oaks Rd and May Green Dr.
Posted Nov 18, 2025 - 14:16 EST
This incident affected: Transportation (Bus 46).