Powerschool SIS - Hosting Performance Degradation
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Nov 30, 2021 - 15:49 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 30, 2021 - 14:31 EST
Investigating
We are currently investigating this issue.
Posted Nov 30, 2021 - 09:24 EST
This incident affected: PowerSchool (PowerSchool Admin, PowerSchool Student & Parent Portal, PowerSchool Teacher).