The following buses will be combined for CMS (Possible Delays) 10/24/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 10:17 EDT

Monitoring

Buses 11 & 31 will be combined on bus 31
Buses 21 & 58 will be combined on bus 58
Posted Oct 24, 2025 - 06:41 EDT
This incident affected: Transportation (Bus 11, Bus 21, Bus 31, Bus 58).