BUS 26 WILL BE PICKING UP BUS 36 CHS STUDENTS- BATTERY CIRCLE/RIVERFRONT
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 09:25 EDT
Investigating
We are currently investigating this issue.
Posted Sep 28, 2022 - 06:11 EDT
This incident affected: Transportation (Bus 36).