Bus 1, 4, 5, 22, 24, 25, 42 & 48 has a sub driver (Possible Delay) 5/3/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted May 03, 2024 - 09:39 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2024 - 06:48 EDT
This incident affected: Transportation (Bus 01, Bus 04, Bus 05, Bus 22, Bus 24, Bus 25, Bus 42, Bus 48).