Bus #32 will not in service today. Bus #17 will take Allison Creek portion of Bus #32's route and Bus #16 will take the remainder of Bus #32.
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 17:20 EST
Investigating
We are currently investigating this issue.
Posted Jan 14, 2022 - 13:57 EST
This incident affected: Transportation (Bus 16, Bus 17, Bus 32).