Bus 1 & 36 are combined on bus 36 for CCE, OMS, CHS/NGC (Possible Delays) 4/16/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 09:42 EDT
Monitoring
The Revere: will ride bus 19 for CCE, bus 49 for OMS, bus 49 for CHS/NGC
Marlin Bay: will ride bus 19 for CCE, bus 27 for OMS, bus 24 for CHS/NGC
Posted Apr 16, 2024 - 06:41 EDT
This incident affected: Transportation (Bus 01, Bus 36).